$re = '/\n\s{4}\"logUser\"(?=.*\:)([\s\:]+)([^\,}]+?)(\,|\})/m';
$str = '{
"abc": 123,
"segundoNivel": {
"logUser": 123,
},
"logUser": 123,
}';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);