import re
regex = re.compile(r".{10}(?=\.mp4\?)", flags=re.MULTILINE)
test_str = ("https://vod-progressive.akamaized.net/exp=1632872807~acl=%2Fvimeo-prod-skyfire-std-us%2F01%2F2551%2F24%2F612755948%2F2854854290.mp4~hmac=4d770f5c491e628b300821f41e47f7779f1a84427631b0a0527577d3cba36915/vimeo-prod-skyfire-std-us/01/2551/24/612755948/2854854290.mp4?filename=FCP_Intro_V1.mp4\n"
"https://vod-progressive.akamaized.net/exp=1632872937~acl=%2Fvimeo-prod-skyfire-std-us%2F01%2F2551%2F24%2F612757540%2F2854880742.mp4~hmac=7933317413b9743c50c3cb5baa5442869608348a9a8e7172e9aa8050452efccd/vimeo-prod-skyfire-std-us/01/2551/24/612757540/2854880742.mp4?filename=FCP_Part_01-V1.mp4\n"
"https://vod-progressive.akamaized.net/exp=1632872951~acl=%2Fvimeo-prod-skyfire-std-us%2F01%2F2552%2F24%2F612764771%2F2854906303.mp4~hmac=613ca7d333a3573a27b52d75d32fc2ab27ab2729b7400766160f5e3b8b12282b/vimeo-prod-skyfire-std-us/01/2552/24/612764771/2854906303.mp4?filename=FCP_Part_02-V1.mp4\n"
"https://vod-progressive.akamaized.net/exp=1632872964~acl=%2Fvimeo-prod-skyfire-std-us%2F01%2F2554%2F24%2F612772604%2F2854936193.mp4~hmac=8c16566b1365ccaa500f5cc4eabd0a4e9b63688b2f23009da477439e124e6921/vimeo-prod-skyfire-std-us/01/2554/24/612772604/2854936193.mp4?filename=FCP_Part_03-V1.mp4\n"
"https://vod-progressive.akamaized.net/exp=1632872974~acl=%2Fvimeo-prod-skyfire-std-us%2F01%2F2555%2F24%2F612777865%2F2854944861.mp4~hmac=341d6b6af273656eea01bee32b8805c54a2fb0918eadb1cf22a63ab7a7069777/vimeo-prod-skyfire-std-us/01/2555/24/612777865/2854944861.mp4?filename=FCP_Part_04-V1.mp4\n"
"https://vod-progressive.akamaized.net/exp=1632872985~acl=%2Fvimeo-prod-skyfire-std-us%2F01%2F2556%2F24%2F612784148%2F2854969449.mp4~hmac=7b8fe71f99097ba2e360dfea9a6c39cc874c33315e7a33f28fa86159cb28814f/vimeo-prod-skyfire-std-us/01/2556/24/612784148/2854969449.mp4?filename=FCP_Part_05-V1.mp4\n"
"https://vod-progressive.akamaized.net/exp=1632873003~acl=%2Fvimeo-prod-skyfire-std-us%2F01%2F2558%2F24%2F612791469%2F2854990882.mp4~hmac=bb6bace0fa1d53004ecc82b95a79b686794be97120b20e7fa4c421f86b3c6bc2/vimeo-prod-skyfire-std-us/01/2558/24/612791469/2854990882.mp4?filename=FCP_Part_06-V1.mp4\n"
"https://vod-progressive.akamaized.net/exp=1632873014~acl=%2Fvimeo-prod-skyfire-std-us%2F01%2F2559%2F24%2F612797974%2F2855015672.mp4~hmac=2290e8bb153512fcd4138651c04c940905ff63cc811fbcdcd040a2f1c23ca962/vimeo-prod-skyfire-std-us/01/2559/24/612797974/2855015672.mp4?filename=FCP_Part_07-V1.mp4\n"
"https://vod-progressive.akamaized.net/exp=1632876856~acl=%2Fvimeo-prod-skyfire-std-us%2F01%2F2561%2F24%2F612805911%2F2855039388.mp4~hmac=c8029598b33a5784281b41967b397cd30f99ee43970ab8a47c1d6e9adaf8c02d/vimeo-prod-skyfire-std-us/01/2561/24/612805911/2855039388.mp4?filename=FCP_Part_08-V1.mp4\n"
"https://vod-progressive.akamaized.net/exp=1632876873~acl=%2Fvimeo-prod-skyfire-std-us%2F01%2F2562%2F24%2F612813308%2F2855059409.mp4~hmac=537378d97e7a94dd29e86f19bcad6a8edf904179cfd0986e605a34255f72fc77/vimeo-prod-skyfire-std-us/01/2562/24/612813308/2855059409.mp4?filename=FCP_Part_09-V1.mp4\n"
"https://vod-progressive.akamaized.net/exp=1632876887~acl=%2Fvimeo-prod-skyfire-std-us%2F01%2F2563%2F24%2F612819768%2F2855077281.mp4~hmac=b571768161a24b07003b4557d9a7c2ce697af3e304a4ccc274ed68d9c3aa5de0/vimeo-prod-skyfire-std-us/01/2563/24/612819768/2855077281.mp4?filename=FCP_Part_10-V1.mp4\n"
"https://vod-progressive.akamaized.net/exp=1632876900~acl=%2Fvimeo-prod-skyfire-std-us%2F01%2F2565%2F24%2F612825555%2F2855103691.mp4~hmac=3636ef96d4ee92193a5e7ae6e625c35601385a654a5a0399b9b57273eacee015/vimeo-prod-skyfire-std-us/01/2565/24/612825555/2855103691.mp4?filename=FCP_Part_11-V1.mp4\n"
"https://vod-progressive.akamaized.net/exp=1632876911~acl=%2Fvimeo-prod-skyfire-std-us%2F01%2F2566%2F24%2F612833279%2F2855128651.mp4~hmac=03c42e9d53e7de67bff558f55583c342e587c714fc90014246da57858ef6e23b/vimeo-prod-skyfire-std-us/01/2566/24/612833279/2855128651.mp4?filename=FCP_Part_12-V1.mp4\n"
"https://vod-progressive.akamaized.net/exp=1632876922~acl=%2Fvimeo-prod-skyfire-std-us%2F01%2F2568%2F24%2F612842031%2F2855134919.mp4~hmac=4184f446ae551b9bb916de508fde8f4ab0149524dfc4ea32581841d94166e3c9/vimeo-prod-skyfire-std-us/01/2568/24/612842031/2855134919.mp4?filename=FCP_Part_Outro-V1.mp4\n"
"https://vod-progressive.akamaized.net/exp=1632876934~acl=%2Fvimeo-prod-skyfire-std-us%2F01%2F2532%2F24%2F612660180%2F2854543774.mp4~hmac=b7f2b8ac4eb51160c482c14730c696ac38b28ff43c347fb4b7c9100c2850d92a/vimeo-prod-skyfire-std-us/01/2532/24/612660180/2854543774.mp4?filename=FADB_OUTRO_V1_1.mp4\n"
"https://vod-progressive.akamaized.net/exp=1632876948~acl=%2Fvimeo-prod-skyfire-std-us%2F01%2F2532%2F24%2F612662874%2F2854565373.mp4~hmac=abf2659663b083af85518f3797212822467e118b9b2bf1e9687a83b88ed4f700/vimeo-prod-skyfire-std-us/01/2532/24/612662874/2854565373.mp4?filename=FADB_Part_01_V1.mp4\n"
"https://vod-progressive.akamaized.net/exp=1632876961~acl=%2Fvimeo-prod-skyfire-std-us%2F01%2F2533%2F24%2F612668762%2F2854588595.mp4~hmac=82de4f060321744ea773b06b7499593356deef781a1bee4bfedff1ddd78d8c84/vimeo-prod-skyfire-std-us/01/2533/24/612668762/2854588595.mp4?filename=FADB_Part_02_V1.mp4\n"
"https://vod-progressive.akamaized.net/exp=1632876971~acl=%2Fvimeo-prod-skyfire-std-us%2F01%2F2535%2F24%2F612676724%2F2854606155.mp4~hmac=140a7c348205e349cbdc19b85268a3adca070168c458f7aa8a0b7cb133fcc96a/vimeo-prod-skyfire-std-us/01/2535/24/612676724/2854606155.mp4?filename=FADB_Part_03_V1.mp4\n"
"https://vod-progressive.akamaized.net/exp=1632876981~acl=%2Fvimeo-prod-skyfire-std-us%2F01%2F2536%2F24%2F612682191%2F2854628176.mp4~hmac=993b2b558bf0685e08947f7a7b6087308a7aaa78ead7017768dd4a0c94d4533b/vimeo-prod-skyfire-std-us/01/2536/24/612682191/2854628176.mp4?filename=FADB_Part_04_V1.mp4\n"
"https://vod-progressive.akamaized.net/exp=1632876991~acl=%2Fvimeo-prod-skyfire-std-us%2F01%2F2537%2F24%2F612688996%2F2854668966.mp4~hmac=f0cc003f0eb228f0eb136561821846b43036dd92d60eae9a7480d217fd9853cd/vimeo-prod-skyfire-std-us/01/2537/24/612688996/2854668966.mp4?filename=FADB_Part_05_V1.mp4\n"
"https://vod-progressive.akamaized.net/exp=1632877001~acl=%2Fvimeo-prod-skyfire-std-us%2F01%2F2540%2F24%2F612700386%2F2854683847.mp4~hmac=c7f0897f3e5a838b73354ff814e3f505ffc7ca037da903d6f8c6564da34ccdd9/vimeo-prod-skyfire-std-us/01/2540/24/612700386/2854683847.mp4?filename=FADB_Part_06_V1.mp4\n"
"https://vod-progressive.akamaized.net/exp=1632877012~acl=%2Fvimeo-prod-skyfire-std-us%2F01%2F2541%2F24%2F612705117%2F2854708942.mp4~hmac=8fc2d1904900cddcf64fed88baca23ffb765eed65502cd8fb22f78874b67efd7/vimeo-prod-skyfire-std-us/01/2541/24/612705117/2854708942.mp4?filename=FADB_Part_07_V1.mp4\n"
"https://vod-progressive.akamaized.net/exp=1632877021~acl=%2Fvimeo-prod-skyfire-std-us%2F01%2F2542%2F24%2F612712006%2F2854760656.mp4~hmac=61f1fab77f856792cf662508f6a7ffa34f599730177ff002917f9e0b7fe6e14f/vimeo-prod-skyfire-std-us/01/2542/24/612712006/2854760656.mp4?filename=FADB_Part_08_V1.mp4\n"
"https://vod-progressive.akamaized.net/exp=1632877032~acl=%2Fvimeo-prod-skyfire-std-us%2F01%2F2545%2F24%2F612728717%2F2854789792.mp4~hmac=b5c6e7de91312c9f4fb388137d4091b318671d988a5c372092001544fd543287/vimeo-prod-skyfire-std-us/01/2545/24/612728717/2854789792.mp4?filename=FADB_Part_09_V1.mp4\n"
"https://vod-progressive.akamaized.net/exp=1632877042~acl=%2Fvimeo-prod-skyfire-std-us%2F01%2F2547%2F24%2F612736541%2F2854807796.mp4~hmac=ded1598d8f614f20ddad15d0e8acbc7ffe93933551673e05f26cd1ee10d1329b/vimeo-prod-skyfire-std-us/01/2547/24/612736541/2854807796.mp4?filename=FADB_Part_10_V1.mp4\n"
"https://vod-progressive.akamaized.net/exp=1632877052~acl=%2Fvimeo-prod-skyfire-std-us%2F01%2F2719%2F24%2F613599959%2F2857364888.mp4~hmac=ea1e6698ed528d1b7354e60c40668b01688f5f11676c0136b1fe6158c967b722/vimeo-prod-skyfire-std-us/01/2719/24/613599959/2857364888.mp4?filename=Real+Estate+Economics+-+Part+01.mp4\n"
"https://vod-progressive.akamaized.net/exp=1632877060~acl=%2Fvimeo-prod-skyfire-std-us%2F01%2F2726%2F24%2F613630518%2F2857445166.mp4~hmac=0380e3ab10c5f524e432f202577bb74c9cd2c6d20d7ff4fb86b349a06d4a6ce0/vimeo-prod-skyfire-std-us/01/2726/24/613630518/2857445166.mp4?filename=Real+Estate+Economics+-+Part+02.mp4\n"
"https://vod-progressive.akamaized.net/exp=1632877069~acl=%2Fvimeo-prod-skyfire-std-us%2F01%2F2732%2F24%2F613664202%2F2857559645.mp4~hmac=3b71ad3290ce0e5ddfb447562cafbd9d4251e6c49ffbd08c704d9bee534645b3/vimeo-prod-skyfire-std-us/01/2732/24/613664202/2857559645.mp4?filename=Real+Estate+Economics+-+Part+03.mp4\n"
"https://vod-progressive.akamaized.net/exp=1632877080~acl=%2Fvimeo-prod-skyfire-std-us%2F01%2F2739%2F24%2F613696989%2F2857665770.mp4~hmac=6dd80eaee204d2ff01aa962666cea9138f18c41d04116e6149a24cf1313f3651/vimeo-prod-skyfire-std-us/01/2739/24/613696989/2857665770.mp4?filename=Real+Estate+Economics+-+Part+04.mp4\n"
"https://vod-progressive.akamaized.net/exp=1632877092~acl=%2Fvimeo-prod-skyfire-std-us%2F01%2F2745%2F24%2F613729885%2F2857780879.mp4~hmac=c2a720ddb64734c5d40e532d964f5989646ea5103ff87652c952b6c3a46e0607/vimeo-prod-skyfire-std-us/01/2745/24/613729885/2857780879.mp4?filename=Real+Estate+Economics+-+Part+05.mp4\n"
"https://vod-progressive.akamaized.net/exp=1632877102~acl=%2Fvimeo-prod-skyfire-std-us%2F01%2F2754%2F24%2F613770514%2F2857977315.mp4~hmac=e6ffb5c295f6a56fcf1607f9807c715543b5f476a674367fda2c283e5d3179eb/vimeo-prod-skyfire-std-us/01/2754/24/613770514/2857977315.mp4?filename=Real+Estate+Economics+-+Part+06.mp4\n"
"https://vod-progressive.akamaized.net/exp=1632877112~acl=%2Fvimeo-prod-skyfire-std-us%2F01%2F2770%2F24%2F613851056%2F2858104953.mp4~hmac=7ce066b806e29877822c53dabc8fc9215990e72597308566544fb2e23cbb4872/vimeo-prod-skyfire-std-us/01/2770/24/613851056/2858104953.mp4?filename=Real+Estate+Economics+-+Part+07.mp4\n"
"https://vod-progressive.akamaized.net/exp=1632877121~acl=%2Fvimeo-prod-skyfire-std-us%2F01%2F2777%2F24%2F613889999%2F2858266208.mp4~hmac=0436ff9f2ea8b17ac04ef8b1ca23cc3b2142c81a2015d748b81f1b6e15cee237/vimeo-prod-skyfire-std-us/01/2777/24/613889999/2858266208.mp4?filename=Real+Estate+Economics+-+Part+08.mp4\n"
"https://vod-progressive.akamaized.net/exp=1632877130~acl=%2Fvimeo-prod-skyfire-std-us%2F01%2F2787%2F24%2F613935072%2F2858359145.mp4~hmac=717a49180743b890b89c1fb0986a748f796da0b21102bb917664e6c9f1079ba6/vimeo-prod-skyfire-std-us/01/2787/24/613935072/2858359145.mp4?filename=Real+Estate+Economics+-+Part+09.mp4\n"
"https://vod-progressive.akamaized.net/exp=1632877139~acl=%2Fvimeo-prod-skyfire-std-us%2F01%2F2805%2F24%2F614028876%2F2858693447.mp4~hmac=f1b10d7c4381bfe5af4fb02c7e68c5b1a732fc10e0838b6ea0549f646f3064a5/vimeo-prod-skyfire-std-us/01/2805/24/614028876/2858693447.mp4?filename=Real+Estate+Economics+-+Part+10.mp4\n"
"https://vod-progressive.akamaized.net/exp=1632877148~acl=%2Fvimeo-prod-skyfire-std-us%2F01%2F2819%2F24%2F614096550%2F2858744036.mp4~hmac=5b418dc946953438f40f20b3482716868c8c50a04d91e4c7ff208d0f66499148/vimeo-prod-skyfire-std-us/01/2819/24/614096550/2858744036.mp4?filename=Real+Estate+Economics+-+Part+11.mp4\n")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)