re = /(?<=\$)[_a-zA-Z0-9]+\b|(?<=\${)[_a-zA-Z0-9]+(?=})/m
str = '$verb = verb
${verb}age = verb'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end