#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:[?&]vi?=|\/embed\/|\/\d\d?\/|\/vi?\/|https?:\/\/(?:www\.)?youtu\.be\/)([A-Za-z0-9_\-]{11})"
Local $sString = "https://www.youtube.com/watch?v=0zM3nApSvMg&feature=feedrec_grec_index" & @CRLF & _
"https://www.youtube.com/user/IngridMichaelsonVEVO#p/a/u/1/QdK8U-VIH_o" & @CRLF & _
"https://www.youtube.com/v/0zM3nApSvMg?fs=1&hl=en_US&rel=0" & @CRLF & _
"https://www.youtube.com/watch?v=0zM3nApSvMg#t=0m10s" & @CRLF & _
"https://www.youtube.com/embed/0zM3nApSvMg?rel=0" & @CRLF & _
"https://www.youtube.com/watch?v=KdwsulMb8EQ" & @CRLF & _
"https://youtu.be/0zM3nApSvMg" & @CRLF & _
"//www.youtube-nocookie.com/embed/up_lNV-yoK4?rel=0" & @CRLF & _
"http://www.youtube.com/user/Scobleizer#p/u/1/1p3vcRhsYGo" & @CRLF & _
"http://www.youtube.com/watch?v=cKZDdG9FTKY&feature=channel" & @CRLF & _
"http://www.youtube.com/watch?v=yZ-K7nCVnBI&playnext_from=TL&videos=osPknwzXEas&feature=sub" & @CRLF & _
"http://www.youtube.com/ytscreeningroom?v=NRHVzbJVx8I" & @CRLF & _
"http://www.youtube.com/watch?v=6dwqZw0j_jY&feature=youtu.be" & @CRLF & _
"http://www.youtube.com/user/Scobleizer#p/u/1/1p3vcRhsYGo?rel=0" & @CRLF & _
"http://www.youtube.com/watch?v=cKZDdG9FTKY&feature=channel" & @CRLF & _
"http://www.youtube.com/watch?v=yZ-K7nCVnBI&playnext_from=TL&videos=osPknwzXEas&feature=sub" & @CRLF & _
"http://www.youtube.com/ytscreeningroom?v=NRHVzbJVx8I" & @CRLF & _
"http://www.youtube.com/embed/nas1rJpm7wY?rel=0" & @CRLF & _
"http://www.youtube.com/watch?v=peFZbP64dsU" & @CRLF & _
"http://youtube.com/v/dQw4w9WgXcQ?feature=youtube_gdata_player" & @CRLF & _
"http://youtube.com/?v=dQw4w9WgXcQ&feature=youtube_gdata_player" & @CRLF & _
"http://www.youtube.com/watch?v=dQw4w9WgXcQ&feature=youtube_gdata_player" & @CRLF & _
"http://youtube.com/?vi=dQw4w9WgXcQ&feature=youtube_gdata_player" & @CRLF & _
"http://youtube.com/watch?v=dQw4w9WgXcQ&feature=youtube_gdata_player" & @CRLF & _
"http://youtube.com/watch?vi=dQw4w9WgXcQ&feature=youtube_gdata_player" & @CRLF & _
"http://youtube.com/vi/dQw4w9WgXcQ?feature=youtube_gdata_player" & @CRLF & _
"http://youtu.be/dQw4w9WgXcQ?feature=youtube_gdata_player" & @CRLF & _
"http://youtu.be/afa-5HQHiAs" & @CRLF & _
"http://youtu.be/6dwqZw0j_jY" & @CRLF & _
"http://www.youtube.com/user/SilkRoadTheatre#p/a/u/2/6dwqZw0j_jY" & @CRLF & _
"https://www.youtube.com/watch?v=ishbTyLs6ps&list=PLGup6kBfcU7Le5laEaCLgTKtlDcxMqGxZ&index=106&shuffle=2655" & @CRLF & _
"http://www.youtube.com/v/0zM3nApSvMg?fs=1&hl=en_US&rel=0" & @CRLF & _
"http://www.youtube.com/embed/r1nq87PzecI?rel=0" & @CRLF & _
"http://www.youtube.com/watch?v=0zM3nApSvMg&feature=feedrec_grec_index" & @CRLF & _
"http://www.youtube.com/watch?v=r1nq87PzecI" & @CRLF & _
"http://youtu.be/0zM3nApSvMg" & @CRLF & _
"http://www.youtube.com/watch?v=0zM3nApSvMg#t=0m10s" & @CRLF & _
"http://www.youtube.com/user/IngridMichaelsonVEVO#p/a/u/1/KdwsulMb8EQ" & @CRLF & _
"http://youtu.be/dQw4w9WgXcQ" & @CRLF & _
"http://www.youtube.com/embed/dQw4w9WgXcQ" & @CRLF & _
"https://www.youtube.com/watch?v=r1nq87PzecI" & @CRLF & _
"http://www.youtube.com/v/dQw4w9WgXcQ" & @CRLF & _
"http://www.youtube.com/e/dQw4w9WgXcQ" & @CRLF & _
"http://www.youtube.com/watch?v=dQw4w9WgXcQ" & @CRLF & _
"http://www.youtube.com/?v=dQw4w9WgXcQ" & @CRLF & _
"http://www.youtube.com/watch?feature=player_embedded&v=dQw4w9WgXcQ" & @CRLF & _
"http://www.youtube.com/?feature=player_embedded&v=dQw4w9WgXcQ" & @CRLF & _
"http://www.youtube.com/user/IngridMichaelsonVEVO#p/u/11/KdwsulMb8EQ" & @CRLF & _
"http://www.youtube-nocookie.com/v/6L3ZvIMwZFM?version=3&hl=en_US&rel=0" & @CRLF & _
"http://www.youtube.com/user/dreamtheater#p/u/1/oTJRivZTMLs" & @CRLF & _
"https://youtu.be/oTJRivZTMLs?list=PLToa5JuFMsXTNkrLJbRlB--76IAOjRM9b" & @CRLF & _
"http://www.youtube.com/watch?v=oTJRivZTMLs&feature=youtu.be" & @CRLF & _
"https://youtu.be/oTJRivZTMLs" & @CRLF & _
"http://youtu.be/r1nq87PzecI&feature=channel" & @CRLF & _
"http://www.youtube.com/ytscreeningroom?v=oTJRivZTMLs" & @CRLF & _
"http://www.youtube.com/embed/oTJRivZTMLs?rel=0" & @CRLF & _
"http://youtube.com/v/oTJRivZTMLs&feature=channel" & @CRLF & _
"http://youtube.com/v/r1nq87PzecI&feature=channel" & @CRLF & _
"http://youtube.com/vi/KdwsulMb8EQ&feature=channel" & @CRLF & _
"http://youtube.com/?v=r1nq87PzecI&feature=channel" & @CRLF & _
"http://youtube.com/?feature=channel&v=r1nq87PzecI?rel=0" & @CRLF & _
"http://youtube.com/?vi=oTJRivZTMLs&feature=channel" & @CRLF & _
"http://youtube.com/watch?v=oTJRivZTMLs&feature=channel" & @CRLF & _
"http://youtube.com/watch?vi=KdwsulMb8EQ&feature=channel"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")