$re = '/(?<![@.])\b\d+/m';
$str = 'afa@123
qwqfwf.12314
sdfa 131
sdf,14234
asad
123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);