$re = '/(?m)^(?:(#.*)|([^=]+)=(.*))/';
$str = '#SenderCompID=something
#TargetCompID=something1
SenderCompID=something2
TargetCompID=something3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);