import re
regex = re.compile(r"^(([1-4][/][1-4])*)(([,][1-4][/][1-4])*)(([1-4])*)(([,][1-4])*)$")
test_str = ("4/1,6/5,6/1,1,2,3,4,5\n"
"5,4,3,2,1,1/3,4/4,2/5\n"
"2,5,3,2,1,1/3,4/4,2/5asdf\n"
"1asdf\n"
"4/1\n"
"2/3,1,2,3\n"
",2/3,1,2,3\n"
"2/3,1,2,3,4,5\n"
",2/3,1,2,3,4,5\n"
"5,2/3,1,2,3\n"
"4/1,2/3,1,2,3,4,5\n"
"1/4,2/3,1,2,3,4,5")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")