$re = '/(\b\S.+\b).*\.\s+\K\1/m';
$str = 'This was a hot Summer, and seems not be the first. For my next vacation, I plan on going to Las Vegas. This was a weird Summer indeed.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);