import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=: )(?P<home_team>[\\w ]+) (?P<result>\\d{1,2}-\\d{1,2}) (?P<away_team>[\\w ]+)";
final String string = "Football: Real Madrid 2-1 FC Barcelona\n"
+ "Football: Atletico de Madrid 4-2 Real Madrid";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}