use strict;
my $str = '7835673653678365';
my $regex = qr/(?<=.{12})./mp;
my $subst = '*';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";