use strict;
my $str = '10SGD35/AA501/10SGD35/AA599/10SGD36/AA501/10SGD36AA599/10SGD37/AA501/10SGD37/AA527
10SGD08/AA701/10SGD08/AA704/10SGD09/AA701/10SGD09AA708';
my $regex = qr//(?=AA)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";