using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(PROJETO|PROTOCOLOS)\s+N\s*(º|o)\s+\d+\.\d+,? {1,2}DE {1,2}\d{1,2} {1,2}DE {1,2}\w{4,8} {1,2}DE {1,2}\d{4}.";
string input = @"PROJETO Nº 1.100 DE 28 DE DEZEMBRO DE 2018.
PROJETO No 1.100 DE 28 DE DEZEMBRO DE 2018.
PROTOCOLOS Nº 1.100 DE 28 DE DEZEMBRO DE 2018.
PROTOCOLOS No 1.100 DE 28 DE DEZEMBRO DE 2018.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}