# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(\S*\s)0/\1/gm;t' <<< "+123 1234
+123 0123
+123+123 01234
+123 0123 0023"