$re = '/\[.+: (.+)\]/m';
$str = '[inside: south->closed]
[field: north->closed *east *south->open west]
[field: *east west]
[city(very bright): north east south west up northwest]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);