$re = '/\/news\/([0-9]+)/m';
$str = 'https://qlurapp.dev/news/538243222222/asdkskns';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);