$re = '/^(?:\S+\.\S+?\/|\/)?(\S+)$/m';
$str = 'https://www.asdfasd.com/asdfasd/fa/sd/fa
http://www.asdfasd.com/asdfasd/fa/sd/fa
www.asdfasd.com/asdfasd/fa/sd/fa
asdfasd.com/asdfasd/fa/sd/fa
/asdfasd/fa/sd/fa
asdfasd/fa/sd/fa';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);