package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d+)([^_])`)
var str = `12_34
12XX
12`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}