use strict;
my $str = ';;;;';
my $regex = qr/(?<!^);/p;
my $subst = 'NULL$0';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";