const regex = /(?!.*[.]{2})((https?|http)\:\/\/)?([a-z0-9+!*(),;?&=\$_.-]+(\:[a-z0-9+!*(),;?&=\$_.-]+)?@)?([a-z0-9-.-.]?(?!.*\/).*)\.([a-z]{2,1000})(\:[0-9]{2,5})?(\/([a-z0-9+\$_-]\.?)+)*\/?(\?[a-z+&\$_.-][a-z0-9;:@&%=+\/\$_.-]*)?(#[a-z_.-][a-z0-9+\$_.-]*)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!.*[.]{2})((https?|http)\\:\\\/\\\/)?([a-z0-9+!*(),;?&=\\$_.-]+(\\:[a-z0-9+!*(),;?&=\\$_.-]+)?@)?([a-z0-9-.-.]?(?!.*\\\/).*)\\.([a-z]{2,1000})(\\:[0-9]{2,5})?(\\\/([a-z0-9+\\$_-]\\.?)+)*\\\/?(\\?[a-z+&\\$_.-][a-z0-9;:@&%=+\\\/\\$_.-]*)?(#[a-z_.-][a-z0-9+\\$_.-]*)?', 'gm')
const str = `https://www.amazon/com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}