import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^ # begin of string\n"
+ "(?:(?!(?:\\1|\\2|\\3)).)*? # ungreedy anything that is not captured by group 1,2,or 3\n"
+ " ( # 1th capturing group\n"
+ " (?:\\brain\\b|\\bsunlight\\b|\\bbark) # Alternation group (answers) \\b word-boundaries as needed\n"
+ " )\n"
+ "(?:(?!(?:\\1|\\2|\\3)).)*? # ungreedy anything that is not captured by group 1,2,or 3\n"
+ " ( # 3th capturing group\n"
+ " (?:(?!(?:\\1|\\3))(?:\\brain\\b|\\bsunlight\\b|\\bbark)) # Answers not captured in group 1 or 3\n"
+ " )\n"
+ "(?:(?!(?:\\1|\\2|\\3)).)*? # ungreedy anything that is not captured by group 1,2,or 3\n"
+ " ( # 4th capturing group\n"
+ " (?:(?!(?:\\2|\\3))(?:\\brain\\b|\\bsunlight\\b|\\bbark)) # Answers not captured by group 2 or 3\n"
+ " )\n"
+ "(?:(?!(?:\\1|\\2|\\3)).)* # anything that is not captured by group 1,2,or 3\n"
+ "$ # end of string";
final String string = "rain. bright sunlight. a dog's bark.\n"
+ "rain. bright rain. a dog's bark.\n"
+ "Barksunlight rain\n"
+ "bark sun rain\n"
+ "bar sunlight sunlight\n"
+ "Rain rain rain\n"
+ "sunlight rain bark\n"
+ "Barking dog, sunlight, rainforest\n"
+ "Barking elephant, green Sunlight, purple rain and other non-sense\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS | Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}