package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-Z][a-zA-Z ]*$`)
var str = `Abc def
Abc def
Abc def`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}