# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:(?:(?:mdmcomm|checkin)\.(?:eu|us|jp)|(?:e(?:ba|df|pns)|msp|identity|repository|(?:(?:eu|us|jp)02\.)?protect|(?:(?:eu|us|jp)\.)?mdm)|(?:.*\.a\.ecaserver))|(redirector))\.eset\.(?(1)systems$|com$)?"
test_str = ("eba.eset.com\n"
"edf.eset.com\n"
"epns.eset.com\n"
"msp.eset.com\n"
"identity.eset.com\n"
"repository.eset.com\n"
"*.a.ecaserver.eset.com\n"
"protect.eset.com\n"
"eu02.protect.eset.com\n"
"us02.protect.eset.com\n"
"jp02.protect.eset.com\n"
"redirector.eset.systems\n"
"eu.mdm.eset.com\n"
"us.mdm.eset.com\n"
"jp.mdm.eset.com\n"
"mdm.eset.com\n"
"checkin.eu.eset.com\n"
"checkin.us.eset.com\n"
"checkin.jp.eset.com\n"
"mdmcomm.eu.eset.com\n"
"mdmcomm.us.eset.com\n"
"mdmcomm.jp.eset.com\n")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.