using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s(?:[–-]|by)\s";
string input = @"8. *Lud-in-the-Mist* by Hope Mirrlees
The Half-Killed by Quenby Olsen
1. the Doctrine of Labyrinths By Sarah Monette
no-whitespace
name-with-by Quenby Olsen";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}