import re
regex = re.compile(r"^(?![ ])(?!.*(?:\d|[ ]{2}|[!$%^&*()_+|~=`\{\}\[\]:\";<>?,\/]))(?:(?:e|da|do|das|dos|de|d'|D'|la|las|el|los|l')\s*?|(?:[A-ZàáâäãåąčćęèéêëėįìíîïłńòóôöõøùúûüųūÿýżźñçčšžÀÁÂÄÃÅĄĆČĖĘÈÉÊËÌÍÎÏĮŁŃÒÓÔÖÕØÙÚÛÜŲŪŸÝŻŹÑßÇŒÆČŠŽ∂ð'][^\s]*\s*?)(?!.*[ ]$))+$", flags=re.MULTILINE | re.UNICODE)
test_str = ("Maria Silva\n"
"Maria silva\n"
"maria Silva\n"
"MariaSilva\n"
" Maria Silva\n"
"Maria Silva \n"
"Maria da Silva\n"
"Marina Silva\n"
"Maria / Silva\n"
"Maria . Silva\n"
"Maria Silva\n"
"Maria G. Silva\n"
"Maria McDuffy\n"
"Getúlio Dornelles Vargas\n"
"Maria das Flores\n"
"John Smith\n"
"John D'Largy\n"
"John Doe-Smith\n"
"John Doe Smith\n"
"Hector Sausage-Hausen\n"
"Mathias d'Arras\n"
"Martin Luther King Jr.\n"
"Ai Wong\n"
"Chao Chang\n"
"Alzbeta Bara\n"
"Marcos Assunção\n"
"Maria da Silva e Silva\n"
"Juscelino Kubitschek de Oliveira\n"
"Natalia maria\n"
"Natalia aria\n"
"Natalia orea\n"
"Maria dornelas\n"
"Samuel eto'\n"
"Maria da Costa e Silva\n"
"Samuel Eto'o\n"
"María Antonieta de las Nieves\n"
"Eugène\n"
"Antòny de Homé April\n"
"àntony de Home ùpril\n"
"Antony de Home Aprìl\n"
"Antony1 de Home Ap*ril\n"
"Ap*ril Willians\n"
"Antony_ de Home Apr+il\n"
"Ant_ony de Home Apr#il\n"
"Antony@ de Ho@me Apr^il\n"
"Pierre de l'Estache\n"
"Pierre de L'Estoile\n"
"Akihito\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")