// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^PT(\d+H)?(\d+M)?(\d+S)?$").unwrap();
let string = "PT1H37S
PT1H30M15S
PT0S
PT1H0M0S
PT22H41M59S";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}