$re = '/.*\.(phtml|php|PhP|php5|suspected)$/m';
$str = 'index.php';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);