import re
regex = re.compile(r",\s*((?:(?!\sand\s)[^,])*)(?=[^,]*$)", flags=re.MULTILINE)
test_str = ("flat 1, tower block, 34 long road, Major city\n"
"flat 1, tower block, 34 long road, town and parking space\n"
"34 short road, village on the river and carpark (7X3 8RG)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")