const regex = /^(?![_\d]|.*__)\w*[a-z\d]$/igm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?![_\\d]|.*__)\\w*[a-z\\d]$', 'igm')
const str = `abc
_abc
1abc
abc_
abc1
ab\$c`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}