// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\\x02(01|02|04|06|07|08|09|10|11|12)\\x01").unwrap();
let string = "
9204112055711\\t김은선(39930(\\x010(\\x010\\x015\\x0227\\t620211367364620211358540 복사하여, 승인 처리 되었습니다.\\n
심사자 정밀심사로 재평가 됩니다.\\x0820210330\\x0820210330\\t507030360)(주)에이플러스에셋어드바이저\\x0210\\x010\\x0200\\x0710MS130\\x0bGA1-3지점\\x0820210331\\x12318000840202103308\\x0232\\x010\\x0820210330\\n
HAN WENSHU(36920(\\x010(\\x010\\x015\\t507030360)(주)에이플러스에셋어드바이저\\x0210\\x010\\x0200\\x0710MS140\\x0bGA1-4지점\\x0820210331\\x133170009442021033037\\x0231\\x010\\x0820210330\\n
\\x02(01|02|04|06|07|08|09|10|11|12)\\x01
\\x10\\x13]\\x02\\tErrorCode\\x03\\x08ErrorMsg<0|^|20210331norOnPwas2081811366173150001|^|FNGCTGC3701|^||^|\\x01\\x13\\x02header\\x10\\x13\\x02\"\\x0bparentIndex\\x02\\x01\\x08rowIndex\\x02\\x01\\n";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}