# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\bPIC (?P<pic>(?:[A-Z]\d*\(\d+\))+)[^.\r\n]*\."
test_str = ("either: ' PIC S9(17).' # with 'S9(17)' in Named Capture Group pic\n"
"either: ' PIC S9(13)V9(2).' # with 'S9(13)V9(2)' in Named Capture Group pic\n"
"either: ' PIC S9(9)V9(2) COMP-3.' # with 'S9(9)V9(2)' in Named Capture Group pic\n"
"either: ' PIC X(16).' # with 'X(16)' in Named Capture Group pic\n\n\n"
"12 M-AR03-MONTANT-RDJ PIC S9(17).\n"
" 12 M-AR03-COMPTE-RDJ PIC X(8).\n"
" 09 M-N014-INC-CHARG-AMT-FSOL PIC S9(9)V9(2) COMP-3.\n"
" 09 M-N014-CHARGE-TYPE-FSOL PIC X(5).")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.