$re = '/.*?23/m';
$str = 'hola23adios23blabla';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);