$re = '/[0]+$/m';
$str = '0
000
1230
00123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);