package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:(http|https)(://))`)
var str = `https://www.google.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}