re = /\s+\p{N}{1,3}\s+(?:years?|an(?:née)?s|سنة|سنوات|عاما|साल)/m
str = 'I\'m 24 years old
J\'ai 25 ans
I have 25 year
عندي ٢٣ سنة
I\'m 24 years old
मैं 27 साल का हूँ
J\'ai 25 ans
I have 100 year
أنا 27 عاما
عندي ٢٣ سنة'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end