re = /\(([a-z0-9 ]+), ?([a-z0-9 ]+)\)/
str = '\'(tagname1, tagvalue1),(tagname2,tagvalue2), ( tagname3, tagvalue3 ), (tag name4,tag value4)\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end