re = /[\uE000-\uF8FF]|\uD83C[\uDC00-\uDFFF]|\uD83D[\uDC00-\uDFFF]|[\u2011-\u26FF]|\uD83E[\uDD10-\uDDFF]/m
str = 'This is a test OMG its so not funny but after the emoji there will be text >> 😊 😃 << There was an emoji But lets see if this gets copied over.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end