$re = '/\{(.*?)\}(?![^;])/m';
$str = 'Username={My_{}user};Password={my_pswd}}123}}}kk}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);