import Foundation
let pattern = #"^(\w{3} \d{1,2} \d{2}:\d{2}:\d{2}) (\S+) %AAA-I-(CONNECT|DISCONNECT): New http connection for user (\S+), source (\S+) destination (\S+), (.*)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Feb
Feb 17 10:08:43 2.2.2.2 %AAA-I-DISCONNECT: http connection for user admin, source 1.1.1.1 destination 2.2.2.2 TERMINATED
Feb 17 10:08:47 2.2.2.2 %AAA-I-CONNECT: New http connection for user admin, source 1.1.1.1 destination 2.2.2.2, local user table ACCEPTED.
Dec 1 0:08:43 2.2.2.2 %AAA-I-DISCONNECT: http connection for user admin, source 1.1.1.1 destination 2.2.2.2 TERMINATED
Jan 2 1:08:47 2.2.2.2 %AAA-I-CONNECT: New http connection for user admin, source 1.1.1.1 destination 2.2.2.2, local user table ACCEPTED.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)