#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\w\w\w \d\d? \d\d:\d\d:\d\d) (\S+) %AAA-I-(CONNECT|DISCONNECT): (New )?http connection for user (\S+), source (\S+) destination (\S+),? (.*)$"
Local $sString = "Feb" & @CRLF & _
"" & @CRLF & _
"Feb 17 10:08:43 2.2.2.2 %AAA-I-DISCONNECT: http connection for user admin, source 1.1.1.1 destination 2.2.2.2 TERMINATED" & @CRLF & _
"" & @CRLF & _
"Feb 17 10:08:47 2.2.2.2 %AAA-I-CONNECT: New http connection for user admin, source 1.1.1.1 destination 2.2.2.2, local user table ACCEPTED." & @CRLF & _
"" & @CRLF & _
"Dec 1 00:08:43 2.2.2.2 %AAA-I-DISCONNECT: http connection for user admin, source 1.1.1.1 destination 2.2.2.2 TERMINATED" & @CRLF & _
"" & @CRLF & _
"Jan 2 01:08:47 2.2.2.2 %AAA-I-CONNECT: New http connection for user admin, source 1.1.1.1 destination 2.2.2.2, local user table ACCEPTED." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")