package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\<!\[CDATA\[).*?(\]\]>)`)
var str = `...
<data><![CDATA[a < b]]></data>
...`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}