re = /<[^<>]*>|(?:(?!<[^<>]*>).)+/m
str = '<abc>d<e><f>>>a><<><>>><<><>>ghi<><j><$>>@#$<<<<<><<>><>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end