const regex = /catalog\/(\d+$)|item\/(\d+)(?:$|\/)|item-news-standart-formy\/(\d+)(?:$|\/)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('catalog\\\/(\\d+$)|item\\\/(\\d+)(?:$|\\\/)|item-news-standart-formy\\\/(\\d+)(?:$|\\\/)', 'gm')
const str = `https://www.website.com/catalog/trinkets/item-news-standart-formy/1772/
https://www.website.com/catalog/trinkets/item/1772/
https://www.website.com/catalog/1772
http://www.website.com/catalog/trinkets/item-news-standart-formy/1772/
http://www.website.com/catalog/trinkets/item/1772/
http://www.website.com/catalog/1772
https://website.com/catalog/trinkets/item-news-standart-formy/1772/
https://website.com/catalog/trinkets/item/1772/
https://website.com/catalog/1772
возвращяются \$1
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}