package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)%%\w+%%`)
var str = `%%HELLO_WOLD%%
%HELLO_WOLD%
%%HELLO_WOLD
HELLO_WOLD%%
Test %%HELLO_WOLD%% test
Test %%HELLO_WOLD%%
%%HELLO_WOLD%% test
Test %%%HELLO_WOLD%%% test Test %%%HELLO_WOLD%%% test
Test %%%%%%%%%%%HELLO_WOLD%%%% test
Test %%%%%%%%%%%%HELLO_WOLD%%%%% test
%%%HELLO_WOLD%% test
%HELLO_WOLD% test
test %%%HELLO_WOLD%% test
test %%%HELLO_WOLD%% test
%%%HELLO_WOLD%%
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}