# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^eth\d+(?=:)(?!.*\n.*[^0-9]127\.0\.0\.1[^0-9])"
test_str = ("eth0: flags=73<UP,LOOPBACK,RUNNING> mtu 1500\n"
" inet 127.0.0.1 netmask 255.0.0.0\n"
" inet6 ::1 prefixlen 128 scopeid 0xfe<compat,link,site,host>\n"
" loop (Local Loopback)\n"
" RX packets 0 bytes 0 (0.0 B)\n"
" RX errors 0 dropped 0 overruns 0 frame 0\n"
" TX packets 0 bytes 0 (0.0 B)\n"
" TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0\n\n"
"eth1: flags=73<UP,LOOPBACK,RUNNING> mtu 1500\n"
" inet6 ::1 prefixlen 128 scopeid 0xfe<compat,link,site,host>\n"
" loop (Local Loopback)\n"
" RX packets 0 bytes 0 (0.0 B)\n"
" RX errors 0 dropped 0 overruns 0 frame 0\n"
" TX packets 0 bytes 0 (0.0 B)\n"
" TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.