import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\w)\\b(?:(?<hour_digit>\\d+)(?:\\s*(?:more|another))?\\s*hours?)?(?:(?:\\s*(?:or|up to|and|to))*\\s*(?<minute_digit>\\d+)(?:\\s*(?:more|another))?\\s*minutes?)?(?:(?:\\s*(?:or|up to|and|to))*\\h*(?<second_digit>\\d+)(?:\\s*(?:more|another))?\\s*seconds?)?\\b(?!\\w)";
final String string = "1 second\n"
+ "21 seconds\n"
+ "1 minutes\n"
+ "21 minutes\n"
+ "1 hour\n"
+ "11 hours\n"
+ "2 more seconds\n"
+ "1 more second\n"
+ "12 more minutes\n"
+ "21 more hours\n"
+ "11 hours\n"
+ "5 hours 5 minutes to 6 hours 6 minutes\n"
+ "7 hours 7 minutes\n"
+ "9 hours or up to 10 hours\n"
+ "5 hours and 15 minutes\n"
+ "For the first step, wash the clothes for 15 minutes. While the clothes are washing, hold your breath for up to 5 minutes.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}