$re = '/((?<=[a-z])([A-Z])|(?<=[A-Z])([A-Z][a-z])([a-z]+|[A-Z]+))/m';
$str = 'reCommended for future AutoHotkeyReleases releases.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);