#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:190[0-9]|19[1-9][0-9]|2[01][0-9]{2})(?=\d*ml)(*SKIP)(*FAIL)|\d{1,5}ml"
Local $sString = "Mary had a little lamb 1980750ml" & @CRLF & _
"" & @CRLF & _
"Mary had a little lamb 2087750ml" & @CRLF & _
"" & @CRLF & _
"Mary had a little lamb 1979750ml" & @CRLF & _
"" & @CRLF & _
"Mary had a little lamb 1980750ml" & @CRLF & _
"Test 19819ml" & @CRLF & _
"Test 198218ml" & @CRLF & _
"Test 2123456ml" & @CRLF & _
"Test 20349876ml" & @CRLF & _
"Test 209912345ml" & @CRLF & _
"Test 1999123456ml" & @CRLF & _
"Test 987654321ml" & @CRLF & _
"Test 1988ml" & @CRLF & _
"Test 9999ml" & @CRLF & _
"Test 2000ml" & @CRLF & _
"Test 100ml" & @CRLF & _
"Test 22ml" & @CRLF & _
"Test 9ml" & @CRLF & _
"Test ml" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)