$re = '/.?\[.+/m';
$str = '[Verse 1]
All I learned growing up was that love chewed me up
Spit me out on the pavement next to the cuts
And the blood that my mum and dad would
Always take out on each other
Only thing that I knew that a love could lead me to
Was protecting my sisters from all the cuts
And the blood that my mum and dad would
Always take out on each other
[Pre-Chorus]
Sweetheart, you are
Changing my mind
Sweetheart, you are
Changing my mind
[Chorus]
Nobody taught me how to love myself
So how can I love somebody else?
There ain\'t no excuses
I swеar that I\'m doing my best
Nobody taught me how to love mysеlf
So how can I love somebody else?
I\'m so new to this
I swear that I\'m doing my best
[Post-Chorus]
I won\'t let you down
I won\'t let you down
[Verse 2]
Standing there, you look at me
Understanding everything
Yeah, it\'s so fascinating
You patch up the blood and the cuts
But our blood got mixed up
So I guess we belong to each other
[Pre-Chorus]
Sweetheart, you are
Changing my mind
Sweetheart, you are
Changing my mind
[Chorus]
Nobody taught me how to love myself
So how can I love somebody else?
There ain\'t no excuses
I swear that I\'m doing my best
Nobody taught me how to love myself
So how can I love somebody else?
I\'m so new to this
I swear that I\'m doing my best
[Bridge]
They will try to pay for me to erase all the memories
But I can\'t
When you shine so bright in a spotless mind
Someone gets left behind
[Chorus]
Nobody taught me how to love myself
So how can I love somebody else?
There ain\'t no excuses
I swear that I\'m doing my best
Nobody taught me how to love myself
So how can I love somebody else?
I\'m so new to this
I swear that I\'m doing my best
[Outro]
I won\'t let you down
I won\'t let you down
I won\'t let you down
I won\'t let you down
<span jsname';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);