re = /^#.*$/m
str = '#Start-Date: 2016-11-10 08:19:24
#Date: 2016-08-12 01:46:28
#Fields: date time time-taken c-ip cs-username cs-auth-group x-exception-id sc-filter-result cs-categories cs(Referer) sc-status s-action cs-method rs(Content-Type) cs-uri-scheme cs-host cs-uri-port cs-uri-path cs-uri-query cs-uri-extension cs(User-Agent) s-ip sc-bytes cs-bytes x-virus-id x-bluecoat-application-name x-bluecoat-application-operation x-bluecoat-transaction-uuid x-icap-reqmod-header(X-ICAP-Metadata) x-icap-respmod-header(X-ICAP-Metadata)
#Remark: 4111140007 "fdc-bcoat-2" "140.108.3.12" "GSOCLogFeed"
This#will not be caught by regex
#This again willl be caught'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end