import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\S+\\h-\\h)?\\K\\S+(?:\\h(?!-\\h)\\S+)*\\h*(?:-\\h\\S\\h*)?$";
final String string = "AAA - Something Here \n"
+ "AAA - Something Here - D \n"
+ "Something Here ";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}